Mozilla Firefox将在3月份停止支持所有的NPAPI插件

Mozilla 基金会目前已经宣布将在今年3月7日发布的 Mozilla Firefox v52 版中停止支持所有的 NPAPI 插件。

但当前众多视频网站仍然使用Adobe Flash Player进行视频播放,因此Mozilla Firefox依然还会支持该插件。

需要注意的是基于安全考虑Mozilla Firefox本身并不会附带启用Flash Player,用户需要时需去单独下载适用于Firefox的该插件进行安装。

Mozilla Firefox将在3月份停止支持所有的NPAPI插件

Mozilla在2014年的时候开始逐步停止使用NPAPI插件,在2015年10月Mozilla已经弃用主要的NPAPI插件。

Mozilla 称 NPAPI 代码库不但会拖累整个Firefox浏览器的开发,也会给浏览器引入诸多不必要的安全风险。

对于特殊环境下使用Mozilla Firefox或者是基于该浏览器打造的其他浏览器若仍然需要支持其他NPAPI插件则可以使用Mozilla Firefox ESR版。

Mozilla Firefox ESR版是该浏览器的扩展支持版本,该版本对于 NPAPI 插件的支持工作将持续到ESR v59版

对于绝大多数普通用户来说Mozilla的这个改变不会对我们造成影响,但仍然有不少网站如国内的银行安全控件以及政务网站等还会使用NPAPI类插件。

对于这些还要使用NPAPI插件的网站我们只需临时切换到微软公司的Internet Explorer浏览器即可进行使用。

本文来源 Kaply,由 山外的鸭子哥 整理编辑,其版权均为 Kaply 所有,文章内容系作者个人观点,不代表 蓝点网 对观点赞同或支持。如需转载,请注明文章来源。
扫码关注蓝点网微信公众号

评论:

3 条评论,访客:3 条,站长:0 条
  1. youkuNMB
    youkuNMB发布于: 
    SeaMonkey 2.46 SeaMonkey 2.46 Windows 7 Windows 7

    需要flash的视频网站都是在耍流氓

  2. 木头科学二百五
    木头科学二百五发布于: 
    Google Chrome 58.0.2998.0 Google Chrome 58.0.2998.0 Windows 10 64位版 Windows 10 64位版

    其实现在国产流氓银行和支付工具开始学乖了,有好多都可以不用装什么所谓的“数字证书”和“安全控件”了。HTTPS就够了。

发表评论