Mozilla Firefox v57版开始将不再支持旧版附加组件

Mozilla早在2015年8月就宣布将会变更附件组件的生态体系并彻底弃用基于XPCOM和XUL构建的附加程序。

而新的生态体系则是基于WebExtensions扩展程序API接口, 预计该政策将会在11月份的v57版中正式实施。

新的API接口可以用来开发跨平台跨浏览器的附件组件,该接口与Google Chrome以及Opera的模式相兼容。

因此对于开发者而言可以很轻松的将扩展程序修改并移植到其他的浏览器上而不需要耗费过多的精力去兼容。

Mozilla Firefox v57版开始将不再支持旧版附加组件

不过2015年之后似乎就没有人还记得Mozilla的新政策了, 直到上周Mozilla Firefox v57测试版才揭露此事。

Mozilla产品经理称v57开始浏览器默认就会关闭旧附加组件,正式版将彻底无法使用基于旧系统的附加组件。

此外Mozilla依然还允许开发者上传旧版的附加组件到商店, 但只有旧版Firefox浏览器用户才可以看到它们。

本文来源 ITHOME.TW,由 山外的鸭子哥 整理编辑,其版权均为 ITHOME.TW 所有,文章内容系作者个人观点,不代表 蓝点网 对观点赞同或支持。如需转载,请注明文章来源。
扫码关注蓝点网微信公众号

评论:

3 条评论,访客:3 条,站长:0 条
  1. kapo
    kapo发布于: 
    WebView 4.0 WebView 4.0 Android 6.0.1 Android 6.0.1

    自作孽不可活,走老路子火不起来至少死不了,opera前车之鉴还看不到?

  2. liumuu
    liumuu发布于: 
    Google Chrome 60.0.3112.78 Google Chrome 60.0.3112.78 Windows 10 64位版 Windows 10 64位版

    用的Firefox Developer Edition

  3. kg
    kg发布于: 
    Opera 47.0.2631.55 Opera 47.0.2631.55 Windows 8.1 64位版 Windows 8.1 64位版

    某些国外网站,在早几个版本开始已在讨(争)论webextension,不是”直到上週”突然出现的。

发表评论