开源项目OPENSSH被发现存在安全漏洞可枚举用户名

开源的加密传输项目OPENSSH日前被发现存在高危安全漏洞,借助该漏洞攻击者可获得实际存在的用户名。

当然OPENSSH项目组却对此是嗤之以鼻的,因为该项目组并不认可被发现的漏洞属于严重等级的安全漏洞。

主要原因在于攻击者可以依靠漏洞暴力测试获得潜在的用户名,但并不能将OPENSSH所有用户都枚举出来

开源项目OPENSSH被发现存在安全漏洞可枚举用户名

CVE-2018-15473号漏洞:

该漏洞自1999年的OPENSSH版本就已经存在,黑客使用任意用户名和密码组合进行验证时会出现不同判断。

例如当某个用户名不存在时进行验证OPENSSH返回信息是验证失败,这可以告诉攻击者用户名确实不存在。

但如果某个用户名存在OPENSSH则会在多次密码错误后关闭连接,这可以告诉攻击者刚刚测试的名称正确。

测试完毕后即可再利用密码词典对密码进行长时间爆破直到成功,因为研究人员人为这种也算是严重的漏洞。

CVE-2018-15919号漏洞:

该漏洞同样是可以获得潜在的用户名称然后进行爆破等,漏洞影响自2011年发布以来的所有OPENSSH版本。

不过这个漏洞主要存在于某个附带认证组件中,该组件预装在Fedora、CentOS、红帽企业版等操作系统上。

新版已经对漏洞进行修复:

OPENSSH在上个月已经对CVE-2018-15473号漏洞进行修复,CVE-2018-15919号漏洞则暂时还未被修复。

不过OPENSSH项目组对此并不在意,因为这种暴力测试用户名是否存在并不能真的把所有用户名都测出来。

而且在UNIX生态体系里也只有少数系统才会刻意避免用户名泄露,众多服务器使用的其实都是默认的root

不过OPENSSH项目组也说了这种漏洞修复起来非常简单,因此会在下个版本发布时顺手改改提示进行修复。

本文来源 ITHOME.TW,由 山外的鸭子哥 整理编辑,其版权均为 ITHOME.TW 所有,文章内容系作者个人观点,不代表 蓝点网 对观点赞同或支持。如需转载,请注明文章来源。
扫码关注蓝点网微信公众号

评论:

1 条评论,访客:1 条,站长:0 条
  1. 81192_field
    81192_field发布于: 
    Google Chrome 63.0.3239.132 Google Chrome 63.0.3239.132 Windows 10 64位版 Windows 10 64位版

    “因为研究人员’人为’这种也算”有误

发表评论