安卓新版将逐渐开始限制基于Android 6.0开发的程序

对于用户来说使用的安卓版本越高自然功能越全面也更安全,当然对于多数的开发者们来说也是同样的道理。

然而不管在哪个平台都有开发者不愿意使用新版API 接口,究其原因自然使用旧版接口还有着某些特殊原因。

Android Q版初始代码开始构建:

谷歌此前已经发布Android P正式版并提供代码给厂商适配,而新版本Android Q版即日起也已经开始构建。

面向Android Q版的代码里就包括系统检查API 版本,如果应用程序调用的API 版本过低则会直接弹窗警告

在Android P版里实际也有类似的API 版本检测工作,只是Android P版仅限制基于Android 1.6的API接口。

为什么开发者不愿使用新接口:

正如文章开头所说新版API 接口提供更丰富的功能也更安全,那么为什么还有开发者不愿意使用新版接口呢。

因为随着安卓API 的构建谷歌开始对各种权限控制的越来越严格,以前的宽松对待造成现在的安卓体验不佳。

例如Android 6.0 之后的版本API 对权限控制更严格,于是某些开发者想要获得更多权限就不愿意使用新版。

谷歌即将清查旧版APP:

目前面向谷歌应用商店上架的应用程序必须基于 Android 8.0+,但是以前开发的App暂时还没有这个限制。

不过谷歌称自今年11月起开始清查旧版应用,如果不发布新版本基于Android 8.0+那么谷歌将会对其下架。

直到 Android Q 版也就是明年八月左右,所有旧版App每次打开都会出现弹窗警告提醒开发者和用户更新。

本文由来源 蓝点网 原创,由 山外的鸭子哥 整理编辑,其版权均为 蓝点网 原创 所有,文章内容系作者个人观点,不代表 蓝点网 对观点赞同或支持。如需转载,请注明文章来源。
0

评论:

2 条评论,访客:1 条,站长:1 条

0%好评

  • 好评:(0%)
  • 中评:(0%)
  • 差评:(0%)
  1. heimiao
    heimiao发布于: 

    这个态度好,开发者一个个很了不起的样子,不把用户当人看

发表评论