蓝点网
给你感兴趣的内容

谷歌宣布不再接受以Android 4.0为基础开发的应用程序

给adblock喂食用的1像素图

谷歌应用商店技术经理在安卓开发者博客上宣布谷歌应用商店不再接受基于 Android 4.0 版开发的应用程序。

发布于2011年的Android 4.0 版现在已经很少还有设备使用,即便停止支持也不会对多少用户造成实际影响。

谷歌给出的理由自然功能和安全性方面的:旧版本的SDK 不支持很多新功能且无法为用户提供更安全的环境。

谷歌宣布不再接受以Android 4.0版为基础开发的应用程序

有鉴于此所有提交到谷歌应用商店的应用程序API 级别最低为16、低于该版本的应用程序无法通过谷歌审核。

所幸如果你正在使用Android 4.0的升级版即Android 4.1版那么还可以继续获得支持,当然能升级是最好的。

使用旧版SDK将无法安装应用:

谷歌提醒开发者如果仍然开发基于Android 4.0 的应用程序,那么在版本更高的系统上可能会无法正常运行。

如果开发者依然想要兼容旧版本那么可以基于旧版本开发专门的版本,新版本与旧版本的安装包不可以通用。

对于开发者来说这样的工作可能会比较麻烦,不过现在使用旧版本用户太少了基本也没必要专门的进行适配。

谷歌组件也不再支持Android 4.0:

除应用方面的限制外谷歌也决定Google Play组件不再支持旧版本,使用旧版本将无法再升级到后续的版本。

这意味着如果想要通过Google Play下载和安装应用的话那么基本都凉了,对于尚未更新的应用程序还支持。

此外对于国内用户来说虽然不使用Google Play但也会更坑,因为很多应用只有下载后你才发现无法安装的。


哇哦恭喜您已成功屏蔽了蓝点网的小广告
   
如何禁止系统自动更新到Windows 10 Version 1809版[视频]生命在于折腾系列 虚拟机里玩谷歌原生版安卓系统使用PS命令定时执行自动下载 Windows 10 聚焦壁纸
赞(7) 赞赏支持
转载请注明蓝点网 » 谷歌宣布不再接受以Android 4.0为基础开发的应用程序
分享到: (0)
蓝点网小程序

评论 1

评论前必须登录!

 

  1. #1
    Google Chrome 67.0.3396.87 Google Chrome 67.0.3396.87 Windows 10 64位版 Windows 10 64位版

    这个规定真好,国内的开发者一个个觉得自己了不得,真该治治

    heimiao3天前

如果本文对您所有帮助,请赞赏作者进行支持呦~

支付宝扫码打赏

微信扫码打赏