当前位置:首页-正文

谷歌表示中国的安卓应用商店也将提高 API 级别至26版

安卓开发者博客最新刊文称2019年谷歌对于安卓应用将提出更多要求,例如API版本最低要达到Android 9。

要求开发者提高 API 级别主要是提高安卓生态的安全性,使用更现代的API版本有助于提高安全和隐私性能。

自2018年11月以来谷歌应用商店上的所有新版本应用都以更新为API 26级别(对应Android 8.0)或更高版本。

为继续提高体验谷歌2019年计划如下:

2019年8月:要求所有新提交的应用程序对应的 API 级别至少为28或以上,对应着Android 9.0及以上版本。

2019年11月:要求对现有的也就是旧版本的安卓应用程序进行更新,新版本 API 级别至少为28或以上版本。

中国区应用商店的下载分发:

谷歌在博客中还特地提到因特殊原因无法使用谷歌商店的中国用户们,这些用户主要依靠中国应用商店下载。

谷歌称中国的安卓应用商店例如华为、OPPO、小米、百度、阿里巴巴以及腾讯等也会提高API 级别至26版。

后续谷歌也将继续与中国公司合作提高安卓生态系统的安全性,因为大多数恶意软件都是针对低API 级别的。

谷歌还将通过保护程序警告旧版应用:

谷歌表示从应用商店外检测到的恶意软件里超过95%都是针对 API 22 或者以下版本的用来绕过权限控制等。

为避免用户遭到恶意软件攻击并支持提高安卓生态安全,谷歌在 2019 年里还会作出以下措施推进版本更新:

2019年8月:如果新开发提交的应用程序级别低于API 26级别则在安装期间会收到Play Protect 发出的警告。

2019年11月:如果现有应用程序的新版本未更新到API 26 或以上级别则在安装期间收到Play Protect 警告。

此后谷歌会在每年安卓新版本发布后即推进API 版本的更新,以确保所有用户都可以获得更安全的使用体验。

本文来源蓝点网 编译,由山外的鸭子哥转载或编译发布,如需转载请联系原作者。

相关文章

换一批