VMware Workstation Pro现已兼容微软HYPER-V虚拟机可以直接并存

正常情况下若启用微软开发的HYPER-V虚拟机软件后,戴尔旗下的 VMware Workstation 就会产生兼容性问题。

无法兼容的原因在于这些虚拟化软件都基于CPU底层的Hypervisor机制实现 , 而各个软件都需要独占虚拟监视器。

这个问题导致用户通常只能选择某款虚拟机软件无法选择其他的, 所以微软默认情况下不会启用HYPER-V虚拟机。

当用户启用HYPER-V虚拟机后就不再与其他虚拟机软件兼容, 除非先回到控制面板将微软的虚拟机软件直接关闭。

VMware Workstation Pro现已兼容微软HYPER-V虚拟机可以直接并存

目前VM与微软的兼容性已解决:

据VMware官方消息,在最新版的 VMware Workstation Pro 15.5.5 中已经可以与微软的HYPER-V虚拟机兼容。

该公司并未透露具体是怎么解决以往的虚拟兼容问题的,但看起来这其中应该是戴尔与微软共同合作得到的结果。

因为不论是宿主机还是虚拟机都必须是 Windows 10 Version 2004 版,低于该版本的话仍然会与微软出现故障。

所以用户要是想同时使用不同的虚拟机软件还需要升级到最新版本,不是最新版的话安装时就会产生兼容性提示。

操作系统、软件和硬件要求:

操作系统方面宿主机也就是物理机仅支持Windows 10 Version 2004 / 20H1 Build 19041.264及后续的新版本。

来宾操作系统方面支持Windows 10 Version 2004、Ubuntu 20.04 LTS 以及Fedora 32版,其他版本均不支持。

虚拟机操作系统方面仅支持Windows 10 Version 2004和Ubuntu 20.04 LTS,其他版本和低于以上版本不支持。

最后硬件方面英特尔处理器至少为Sand Bridge架构及后续新款,AMD处理器至少Bulldozer推土机及后续新款。

下载VMware Workstation Pro 15.5.5版及后续新版本 :https://www.vmware.com/go/getworkstation-win

本文来源 蓝点网,由 山外的鸭子哥 整理编辑,其版权均为 蓝点网 所有,文章内容系作者个人观点,不代表 蓝点网 对观点赞同或支持。如需转载,请注明文章来源。
扫码关注蓝点网微信公众号

评论:

3 条评论,访客:3 条,站长:0 条
  1. 木头科学二百五
    木头科学二百五发布于: 
    Chromium Edge 85.0.536.0 Chromium Edge 85.0.536.0 Windows 10 64位版 Windows 10 64位版

    哈哈哈 VMware 和 VirtualBox 终于都归顺了!这下子这两款虚拟机可以和 WSL2 以及 docker 并存了。

    • 山外的鸭子哥
      山外的鸭子哥发布于: 
      Google Chrome 83.0.4103.61 Google Chrome 83.0.4103.61 Windows 10 64位版 Windows 10 64位版

      AMD推土机及后续CPU可以

发表评论